Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE  (Read 1112919 times)

0 Members and 1 Guest are viewing this topic.

Offline mgb204

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4600 on: September 14, 2020, 02:01:51 PM »
1-tile X 3-tile FTLs are broken, the outer parts of the intersection are mirrored. This isn't just the visuals, either, paths are affected, rendering them unusable. Going by the attached image, they seem to be rotated/swapped around.

So far as I know, itía a LHD problem from NAM 36, itís been reported, but requires a special LHD implementation to fix.

Online Opkl

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4601 on: September 14, 2020, 03:55:18 PM »
Not sure if this has been reported or not, but the original TuLEP rail crossings appear to be missing paths. The new Flex Turning lanes DO work, but lack the street lighting/ rail gantry props by Jondor.




Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11458
  • Total likes: 5010
  • Reputation: 73
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4602 on: September 14, 2020, 11:05:54 PM »
Not sure if this has been reported or not, but the original TuLEP rail crossings appear to be missing paths. The new Flex Turning lanes DO work, but lack the street lighting/ rail gantry props by Jondor.

The missing paths are likely the result of all the Rail crosslink removal we had to do during NAM 37 development.  The whole matter of Maxis Rail vs. RealRailway (RRW) and the conflicts between the two standards required us to remove pretty much anything Maxis Rail-related from almost every plugin in the NAM, allowing things to fall back on the support included in the RRW, but being that TuLEPs are basically a Legacy Support item now, not in active development or maintenance, it appears RRW-compliant paths weren't made. 

jondor has given us blanket permission to do what we wish with his props, and there's interest within the NAM Team to expand support with those, so the prospect of an update with FTL coverage is quite likely.

-Alex

Offline Synthael

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4603 on: September 15, 2020, 09:28:13 AM »
Hey,

Found out a "glitch" in the system, RHW6S is not showing on region view. I noticed it while connecting two of my cities, RHW's 2, 4, 8S and 8C are appearing normally, only 6S is "missing". Attached pictures with where it's missing and how it should appear.

Thanks for all the hard work over the years.  :thumbsup:

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11458
  • Total likes: 5010
  • Reputation: 73
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4604 on: September 15, 2020, 06:07:06 PM »
The issues with the RHW-6S and the regional satellite view have been known for quite awhile--they're specifically tied to the Euro textures.  It's related to some obscure issue relating to embedded mipmaps with those textures.  There have been attempts to address it in the past, and those attempts have only broken it further, resulting in texture issues with the network while in a city tile, and sometimes even CTDs. 

Unfortunately, as such, I'd honestly be really surprised if it ever got fixed. 

-Alex

Offline Synthael

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4605 on: September 16, 2020, 12:31:20 AM »
Ah, so it is an old one which is just very elusive :D

I don't mind it too much, it's just when I stop playing for some time I tend to forget on the bug and then get back to the tile thinking I didn't connect it properly or that the update borked it xD

Keep on, team :D

Offline d4star

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4606 on: September 17, 2020, 04:18:28 PM »
HELP!
I installed the new NAM and now my SC4 crashes upon loading a city. All goes well and the city starts to load. The program just ends right before the city should appear. Win10, Steam. (which I thought was on the good list). Removed all the old files from Plugins and did the install.
What is the best route to restore?
Thanks
Dave

Offline Tyberius06

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4607 on: September 17, 2020, 04:50:13 PM »
HELP!
I installed the new NAM and now my SC4 crashes upon loading a city. All goes well and the city starts to load. The program just ends right before the city should appear. Win10, Steam. (which I thought was on the good list). Removed all the old files from Plugins and did the install.
What is the best route to restore?
Thanks
Dave

Have you used the 4GB patch? It's like one of the most important thing what you must do if you install any new NAM. You need to patch the game SimCity4.exe with the 4GB patch.

Quote from the readme:
Quote
Note that the NTCore 4GB Patch is REQUIRED, and due to the installer change, is no longer installed by default.  The patch can be found inside the download, or downloaded directly from NTCore here, where further instructions on use of the patch can be found.  Also due to this installer change, the NAM Controller Compiler is no longer run as part of the installation process. All users will be initially given a full NAM Controller, which has a substantial size.  Users not using all features wishing to have a smaller controller can still run the Controller Compiler manually, as it is available in the download.  Those on 32-bit versions of Windows should proceed with caution.

Also more information:
Quote
A Note About the "4GB Patch"

Due to changes in computer systems, and continued expansions of the NAM's main Controller file, in 2013, it was determined that many newer systems, particularly those with more than 4GB of RAM, and running 64-bit versions of Windows, need additional accommodation.  To that end, the NAM includes a "4GB Patch", also known as a "Large Address Aware (LAA) Patch", which allows the game to access the full 4GB of RAM that a 32-bit application can read, instead of the default 2GB.  The NAM's patch was designed by NTCore, and built into the NAM with permission, and users with systems that need the patch will receive a prompt during NAM installation to install it.  The original patch can be found here.

The only thing this patch does is to switch the Large Address Aware switch, an accessible switch present in all Windows executables, from "off" to "on" for the game's executable.  Patches like this are common in game modding communities, including those associated with Skyrim, Fallout, and Morrowind, and can be used to enhance any 32-bit application's performance on systems with 64-bit operating systems and a suitable amount of RAM.

The default directory for where SimCity 4.exe may be located depends on how and where you purchased your copy of the game.
 
GOG.com: C:\GOG Games\SimCity 4 Deluxe Edition\Apps
Steam: C:\Program Files (x86)\Steam\steamapps\common\SimCity 4 Deluxe\Apps
Original Disc: C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps
Origin*: C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps
*Note that only Origin copies acquired through Free CD Key Redemption (Version 1.1.641) are compatible with the NAM.  Copies purchased through the Origin Store or accessed via Origin Access (Version 1.1.610) ARE NOT COMPATIBLE.  See here for more details.

- Tyberius
You may find updates about my ongoing projects into my development thread here at SimCity 4 Devotion: Tyberius Lotting Experiments
or over there on Simtropolis into the Tyberius (Heretic Projects) Lotting and Modding Experiments.
I'm also member of the STEX Custodian and working on different restoration projects on behalf of non-anymore-active custom content creators.
Current projects: WMP Restoration and SimCity Polska Restoration.
Member of the NAM Team and RTMT Team.

Offline d4star

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4608 on: September 17, 2020, 06:49:51 PM »
Thank You!

I thought I had lost it. I apparently misapplied the patch. This time it came back with a positive result and the city loaded.