Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE  (Read 1127272 times)

Danss123 and 1 Guest are viewing this topic.

Offline jeffryfisher

  • Uncle Jeff
  • Forums Citizen
  • *
  • Posts: 57
  • Total likes: 52
  • Reputation: 0
  • The most local level of gov't is one citizen
    • Liberating Digital Content
Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4620 on: October 18, 2020, 11:18:47 AM »
I spent the next few hours going through process of elimination, transferring my plugins from the old folder to new in small batches... With 11 gigabytes of plugins to transfer, you can imagine this took a while.

For reference's sake, the two were Element's "No More Dozer" mod and "JCS_TunnelAndSlopeMod".
Glad you found the culprits; the JCS one might have come up in a file-search, but "No More Dozer" is not obvious at all. I hope your process of elimination was the relatively efficient "binary search" where you add half of your plugins and then (depending on result) either add or remove half of half.

Do you have DataNode on your machine? It is a custom SC4 tool that will load your entire plugins folders and then tell you what mods are overriding what other mods (down to the exemplar level). With that tool, you could have found any "slope" exemplar to see what it was overriding / overridden by (and what file names were involved). Future visitors who read this thread should give it a try before suffering through a tedious brute-force testing process.
Modding PC games since 1993 (back when we needed hex-editors)

Offline roadgeek

Re: NAM Issues Thread - PLEASE POST YOUR NAM QUESTIONS AND PROBLEMS HERE
« Reply #4621 on: Yesterday at 03:13:04 PM »
Roadgeek, assuming you are on a windows system via running the game windowed what you do is press the Prt Scrn Sys Rq button on your keyboard and instantly open MS Paint, go to Edit then Paste immediately. It should then show up assuming you didn't close the traffic view sub menu ...but to the best of my knowledge not being a coder, unfortunately the game thinks those are intersections hence the red light tiles. I ain't a programmer so unfortunately I got no resolve for that.

Thanks.