Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: More...NAM 36 on Mac problem with FTL and QuickTurns  (Read 1151 times)

0 Members and 1 Guest are viewing this topic.

Offline Rpbaileysr

More...NAM 36 on Mac problem with FTL and QuickTurns
« on: June 28, 2019, 02:59:37 PM »
Still looking for help on missing pieces in FTL and QuickTurns icons. I'm on a 2010 MacBook running High Sierra 10.13.6  . I'm using SimCity4 RH from aspyr from the app store. Look at posts on Simtropolis,
  https://community.simtropolis.com/forums/topic/75729-sc4-and-macos-sierra-high-sierra/
you can see what I've been doing to try to fix it and I posted some screen shots. If you need more info just let me know. thanks all.

Added info..after browsing the manuals I found I'm using "NetworkAddonMod Controller Version RHD_2015 Dec 25-09:12:58(UTC).

I also tried to make some road slip lanes and that is not working either.

I'm looking everywhere to try to find an answer and fix this problem.

Any help please?
« Last Edit: June 29, 2019, 11:25:27 AM by Rpbaileysr »

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11468
  • Total likes: 5048
  • Reputation: 73
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: More...NAM 36 on Mac problem with FTL and QuickTurns
« Reply #1 on: June 29, 2019, 05:59:01 PM »
Thanks for the update on what the NAM Controller icon is saying.  If your controller file says 2015 Dec 25, that would mean that the controller the game is actually loading is from NAM 34.  That effectively demonstrates that you have pieces of NAM 34 laying around your Plugins folder, and they're loading after the Controller file I linked you to over at Simtropolis, thereby preventing your FTLs and QuickTurn from showing up in-game.

The typical recommended installation procedure for the NAM on Mac involves using memo's JDatPacker to merge the NAM installation into a smaller number of files.  This is something we actually discourage on the Windows end, because of the potential for the sort of issue you're encountering, but the Mac version has the bizarre "number of files" limit, which will cause the game to crash/run extraordinarily slow if the number of files in the Plugins folder is over a certain threshold.

JDatPacker usually takes the folder name, and appends a three-digit number to it for the name of the merged file--i.e. Network Addon Mod_000.dat, etc.  Do a search on your Plugins folder for "Network Addon Mod_0", and you should be able to turn up any such merged files.  Delete those, and then re-merge once you've successfully gotten the FTLs and QuickTurn operating (though remember in the future that you'll need to remove these merged files when the next release arrives).

If that still doesn't do it, do a search for "NetworkAddonMod_Controller", and see if it turns up more than one file.  If so, delete all of them, and re-install the one I linked you.

-Alex

Offline Rpbaileysr

Re: More...NAM 36 on Mac problem with FTL and QuickTurns
« Reply #2 on: June 30, 2019, 12:12:37 PM »
I did the search, Found I had 2 NetworkAddonMod_Controller.dat files , the 2nd one was in the Locale folder. I took out both of them and put back the controller you had me put in before. Yea! I have the FTLs and QuickTurns and the slip lanes are working fine.
I downloaded NAM36 shortly after I bought the aspyr SimCity 4 RH from the appstore. I had no other versions of NAM. Wonder how I got a NAM34 controller. I downloaded " NAM 36 Mac Wrapper.dmg". and followed instructions and got the old controller. That might need fixed so it loads a current controller.
Is the JDatPacker free? My game is running fine as it is for now. I'll have to figure out the packer I guess.
I did put some of Mattb's growables in my plugins. Like his colored row houses, R$, but I kept looking for them to show up but they never did. Is there some certain way to put them in. He says there are no dependencies, just put them in plugins folder. ?
Thanks for all the help with my controller problems.
Robert