Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: Several bugs(?) with NAM mod  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Offline AABBCCD

Several bugs(?) with NAM mod
« on: April 09, 2019, 02:40:27 AM »
Hello great fellows of SC4,

I have been playing this fantastic game for years. Recently, I noticed how good NAM is and started using it. However, there are a few things just not going right in my city. Some of the pieces are not working as I thought. I used "drawpath" and it seems they are not regarded as what they should be. My sims simply act as they do not even exist. I know there are issues in FLUPs showing path arrows so I tried UDI mode to double-confirm and it showed they really not existed to all the vehicles I was in. I have googled several varieties of keywords but not much I can find. Would any of you please, please tell me how to deal with it?  :bnn: :bnn: :bnn:

So I attached all the screenshots below. The first one is a rail go underground through a tram-in-avenue. The tram-in-avenue was from "underground rail tramway intersection pieces" under "miscellaneous transportation" folder which should allow the rail to go under through it.

The second one is a ramp of MHW over tram-in-avenue from custom ramps. It seems like the avenue, the tramway and the MHW are all disconnected. Also when I checked the route query of my sims, they are not taking these ways.

The third one is a piece of El rail turning out of avenue. Same, both the avenue itself and the El rail are not working.

The last one is an El rail bridge that simply not carrying any cars. I tried several bridges when I found this and only railroad bridge and El rail bridge was dysfunction. Road bridges, highway bridges, and even monorail bridges were all properly used by the sim.

Could anyone please give me a hand on all these issues? Thank you guys, you are the best.
« Last Edit: April 09, 2019, 02:49:54 AM by AABBCCD »

Offline Tarkus

  • Administrator
  • Forums Legend
  • *
  • Posts: 11360
  • Total likes: 4263
  • Reputation: 71
  • NAM Team Tankadillo
    • NAM HQ
  • CL: Dr. PuzzlePiece
Re: Several bugs(?) with NAM mod
« Reply #1 on: April 09, 2019, 03:40:33 AM »
Hi AABBCCD--welcome to SC4D!

It looks like, based on your DrawPaths screenshots, that your copy of the game is running in what is (contrary to actual steering wheel side in vehicles) referred to in SC4 transportation terminology as "Left-Hand Driving" (LHD), in which vehicles travel on the left side of the road/tracks.

The way Maxis programmed LHD functionality resulted in paths for car-based networks being automatically flipped in most instances, but not Rail-type networks.  The NAM's LHD settings flip Rail-type networks as well in copies of the game that are in LHD mode (the NAM does not change drive sides, however), through two components: a "path remapping" section in the Network INI file (which is contained in a file known as the "Bridge Controller", since it also handles bridges), and a series of additional path files, which are referred to by the path remapping section.  Some have been merged into their respective NAM components from the outset (mainly in response to a rash of "where's my trains?" tech support cases we got from LHD users failing to install the LHD Support File), but others are still stored in separate files in the LHD Support folder. 

I'd have to switch my game over to LHD and install the NAM in LHD to check to verify the issue, but there's one of two things potentially going on here: (a) it's possible you may not have the LHD support files for those components, and are missing the LHD paths as a result, or (b) those components have not received LHD paths.  A lot of the later Tram-in-Avenue and URail items created around NAM Versions 29 and 30 (2010-2011) ended up not getting LHD support upon their release, though AFAIK, most (if not all) of those were fixed in a later release.

If it's the first case, check to see that you have a folder called "z_Left Hand Plugin" contained within your Plugins\Network Addon Mod folder.  If it's not there, reinstall the NAM, select "Custom Installation", go down to where it says "Traffic Driving Side (usually shouldn't be changed)", click the "+" to expand the options, and make sure "Game traffic drives on left side of road" is selected.

If you do have z_Left Hand Plugin, make sure the files "NetworkAddonMod_LEFT_HAND_VERSIONS_ONLY_Required_Additional_Plugin.dat" and "NetworkAddonMod_Bridges_LEFT_HAND_VERSIONS_ONLY_Required_Additional_Plugin" are contained in the folder.  If not, try re-installing.

If the folder and those two files are there, however, that would likely suggest the path files don't exist, and would need to be made. 

Alternatively, if you'd prefer to have the game run in Right-Hand Driving (RHD) mode, there are ways to do that, either by modifying the game's shortcut, or editing the game's registry entries.

Hope that helps!

-Alex

Offline AABBCCD

Re: Several bugs(?) with NAM mod
« Reply #2 on: April 09, 2019, 05:07:36 PM »
Tarkus, thanks for your help, I am totally good now. As I said, you are the best of the best, not joking!!


Let me explain what happened a little deep into the issue. So I have never heard about the versions and sort of LHD or RHD issues. I bought this copy more than a decade ago that I can hardly remember which origin or version it was. LHD was actually another issue I failed to correct since the first time I noticed it but it didn't bother me much so I have been basically ignoring it. After going through your thread, I jumped all the way down to correct the driving direct issues to see if I can solve all of them at a time.

So, first, I regedited my laptop. The registry entry was 0x12 as the name being TChinese, which should allow RHD. (I am actually a Taiwanese IRL whose native language being traditional Chinese) However, the interesting thing is, I have always been RUNNING THE GAME IN ENGLISH with LHD. In fact, I have never thought of changing the language. For, on one hand, I don't know how to change it, and on the other hand, English has never been an issue to me lol.

Second, I went through all the folders and bingo, I got one folder named "UKEnglish" and nothing was named "English".

So what I did was sort of a combination of both the threads you tagged. I changed the registry entry to 0x01/English. Then I created a folder named "English" before copying the .dat file from "UKEnglish". Then I took the last step to edit my shortcut.

After doing all his, I started the game all over again and all those issues were ALL SOLVED!! Besides, I even learned how to adjust the resolution of the game by accident, which was another minor issue I ignored for a long time.

So, thanks again. I love you guys so much. Cheers!!
« Last Edit: April 09, 2019, 05:10:19 PM by AABBCCD »