Menu

LEX File Exchange EA Support Files
SC4 Wikipedia Network Addon Mod
Dependencies

Author Topic: Strange Things happen with .dat  (Read 251 times)

0 Members and 1 Guest are viewing this topic.

Offline evarburg

  • Forums Governor
  • *
  • Posts: 363
  • Reputation: 0
Strange Things happen with .dat
« on: July 15, 2019, 01:48:53 PM »
“strange things are happening" is what Data Node tells me before freezing up when I am trying to check a dat called Airport Shuttles, as the props don't show up in the Lot Editor. It is a consolidated .dat ; (in the folder are also individual dats for each shuttle ; I've tried also having them separately in my plugins ; no difference). I spotted those Airport Shuttles when looking for airport props, but there is no creator name, and no readme (and I can't find the link again !). My feeling is that this dat is corrupted or badly made ;  When looking at the dats in the Reader, it shows this (see pict). Could someone confirm there is a problem with that .dat (and not with me...) ?

Offline Andreas

  • Administrator
  • Forums Legend
  • *
  • Posts: 4734
  • Reputation: 33
    • SimCityPlaza
  • CL: ()bobby() Transit Controller
Re: Strange Things happen with .dat
« Reply #1 on: July 15, 2019, 02:13:32 PM »
I don't know who made them, but it looks like those are not props, but automata models (they probably show up driving around on your roads when you plop some "airport shuttle" lot). From the screenshot, I can't tell if they are broken, but it's possible that there is a bug in SC4DataNode that prevents it from reading automata files properly.

Offline evarburg

  • Forums Governor
  • *
  • Posts: 363
  • Reputation: 0
Re: Strange Things happen with .dat
« Reply #2 on: July 16, 2019, 09:36:46 AM »
ah, I'd forgotten about automata ! (“You don't know much, Jon Snowette”) Thank you. Not I'll have to go and dust my how-to-make-props-from-automata tutorials, I guess. ;)