Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: Lot Editor on the fritz  (Read 670 times)

0 Members and 1 Guest are viewing this topic.

Offline evarburg

Lot Editor on the fritz
« on: May 20, 2019, 01:41:33 PM »
Hi, y'all. I'm trying to go back on the saddle, beginning with rebuilding (done) and cleaning (WIP) my plugins  To get rid of some non functional textures appearing in the park menu (River Rock-Flagstone-Wet Brick-Brown Neat Brick-Tan Brick all but one are non fuctional) I need to use the L.E. It had somehow disappeared from my tools, so I reinstalled it from the zip I had. Not functioning. I changed zips (I had one from Rivit) and re-reinstalled. Still no luck.  It would be strange that both zips would be corrupted, right ? So it must be something else.

Any idea ?

What is infuriating is that I remember identifying and getting rid of those pesky textures way back then, but I don't remember now where they come from....

I'm using the version of SC4 I bought from Steam, and playing on a virtual windows partition (on a Mac).
« Last Edit: May 20, 2019, 01:52:08 PM by evarburg »

Offline mgb204

Re: Lot Editor on the fritz
« Reply #1 on: May 21, 2019, 11:53:55 AM »
I'm guessing when you installed the Steam version, you uninstalled your old one? Unlike the disc-versions of SC4, the digital ones don't come with the LE application or other tools. Therefore re-installing the LE was necessary, but if it won't run, you probably need to add a command line switch to the LE shortcut. Right click the shortcut, select properties and add the following at the end of the "target" line:

 -d:software

This will make the LE run in a compatibility mode that is commonly necessary. If that doesn't help, it would be useful if you'd give us a bit more information to diagnose the issue. Such as what steps you take and what then does or doesn't happen. Along with any error messages you might be seeing.

As for the lots, I can only guess once more why they have returned. But logically you must have ended up with them being in your Plugins folder once more. So it's the usual story of trawling through your plugins until you can find the files. Unless of course someone else recognises what they are.

Offline evarburg

Re: Lot Editor on the fritz
« Reply #2 on: May 21, 2019, 12:24:07 PM »
Thanks Robin ! But remind me : where is the program supposed to be (in ProgramFilesx86 ?) ; and there are "" in the target line : should I take them out and add  -d:software or should I add it after the " ?

As of now, the program opens the back window, waits, waits and then the warning window opens " Simcity4 Lot Editor ceased to functio”

Offline Andreas

  • Administrator
  • Forums Legend
  • *
  • Posts: 4747
  • Total likes: 943
  • Reputation: 33
    • SimCityPlaza
  • CL: ()bobby() Transit Controller
Re: Lot Editor on the fritz
« Reply #3 on: May 21, 2019, 12:46:37 PM »
Only the program path has to be wrapped with quotation marks, command line arguments are added after that.

Offline evarburg

Re: Lot Editor on the fritz
« Reply #4 on: May 21, 2019, 01:41:28 PM »
OK, thanks !

Still doesn't work, though (placed the files in Programsx86)

I am gonna try with an empty plugins folder

working............................................. working..................................... working.............................................

Obviously not working. Should open almost at once with an empty plugins folder.
--------------
Later : and now it doesn't even want to accept the  -d:software addition, says the path is incorrect or whatever (I have it in French, cannot translate)

BTW : PIM doesn't function either.
« Last Edit: May 21, 2019, 09:54:30 PM by evarburg »

Offline mgb204

Re: Lot Editor on the fritz
« Reply #5 on: May 22, 2019, 02:53:56 AM »
If you move the installation files, but then try to update the shortcut to them, Windows won't know where you've moved the files. Which would explain the incorrect path error.

Here is an example entry:

"C:\Program Files (x86)\SimCity 4\Apps\LotEditor.exe" -d:software

If course I do not use Steam, the location for you will vary, you need to find the install location of the LE, then change the part in blue above to match your setup.

You should almost never need to move any installed application. The last version of Windows to fully support this was 3.11 back in the mid nineties. Today, all applications store data and re-use shared resources, moving applications around without considering this can lead to many unexpected problems. Even if it appears to work, it's almost always a terrible idea unless you fully understand what you are doing.



Note the error you are seeing for PIM-X basically means the application is unable to read the Windows Registry. This is a central location that contains important data, in the case of SC4, where it is installed. Without this data, the app simply doesn't know where to find the SimCity_# dat files it needs. If you are using Win8 / 10, you may find you need to right click the application shortcut and use "Run as Administrator". Otherwise, Windows may simply be refusing to let the application read data from the Registry and also within the Program Files and (x86) variant folders. In fact, that could equally apply to your issues with the regular LE, since that too needs to access files from the SC4 install.

Offline evarburg

Re: Lot Editor on the fritz
« Reply #6 on: May 22, 2019, 07:28:39 AM »
O....K... So, are you telling me to take out those programs and reinstall them (and never move them afterwards, got that ;) ) ?

-----------------
Did reinstall LE from zip  in programFilesx86/MaxisSimcity4 Deluxe/Apps ; did add the command  to shortcut ; tried. Still doesn't work ; but at least it presents me with the first normal windows (“Do you authorize” etc.)

I reboot windows ; I try again ; and now the command is again refused :
« Last Edit: May 22, 2019, 09:58:33 AM by evarburg »

Offline Andreas

  • Administrator
  • Forums Legend
  • *
  • Posts: 4747
  • Total likes: 943
  • Reputation: 33
    • SimCityPlaza
  • CL: ()bobby() Transit Controller
Re: Lot Editor on the fritz
« Reply #7 on: May 22, 2019, 01:37:01 PM »
I'm not 100% sure if it's the case or not, but the error message in the screenshot looks like you are missing a space between the quotation mark after 'LotEditor.exe' and before '-d:Software'. Have a closer look at mbg204's example line. :)

Offline evarburg

Re: Lot Editor on the fritz
« Reply #8 on: May 22, 2019, 09:13:32 PM »
I wish it were that simple ; but I've done it with and without the space and neither work.

Offline evarburg

Re: Lot Editor on the fritz
« Reply #9 on: May 23, 2019, 07:46:59 PM »
Any new ideas ? Anyone ?

Offline evarburg

Re: Lot Editor on the fritz
« Reply #10 on: May 24, 2019, 10:40:30 PM »
Well, the problem was finally solved (I didn't have the right LotEditor installer. Duh) -- it was a joint effort from SC4D and Simtrop' So thanks to everyone !