Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: Problema al actualizar de versión .638 a .640  (Read 2321 times)

0 Members and 1 Guest are viewing this topic.

Offline Alberto García Pastor

Problema al actualizar de versión .638 a .640
« on: December 02, 2017, 01:41:22 PM »
Hola. Muy buenas a todos.
Soy novato en Sim City 4, y estoy teniendo problemas al actualizar mi juego.
Espero que me puedan ayudar.
Tengo una copia virtual de Sim City 4 Deluxe, realizada a un CD original, con un código de activación que tambien es original. Todo prestado por un amigo.
Lo instalo y juego perfectamente.
Hasta ahí bien, el problema comienza cuando al sumergirme en el mundo Simcity4, me encuentro con esta página:
http://sc4devotion.com/forums/index.php?page=7
Procedo a descargar e instalar:
-"Official update for the Rush Hour / Deluxe versions of the game. It updates the RH/Deluxe versions to version EP1 Update 1 / 1.1.638.0."-
en la version de Europa que es la zona a la que pertenece mi juego.
Compruebo la versión en el ejecutable de la carpeta raiz y está actualizado. El juego funciona correctamente.
Descubro el NAM 36... &apls :bnn:
y al poco tiempo leyendo en la web me encuentro que el juego original tiene un problema de crash-to-desktop con las piezas del NAM y que la solución pasa por actualizar el juego a la versión .640 y descargar y copiar el archivo SC4Fix.dll en la carpeta de Plugins de documentos.
Para actualizar a la versión .640 leo que hay que instalar el LotEditor y el BAT, y que para que funcione el BAT necesito el GMAX.
Pues bien:
Descargo e instalo el LotEditor desde la pagina que antes descargue la actualización .638
Descargo e instalo Gmax 1.2 y lo registro con una clave proporcionada por Turbosquid.
Descargo e instalo la ultima versión disponible del BAT y su actualización.
Todo ello desde: http://sc4devotion.com/forums/index.php?page=14
Compruebo que el LOT y el BAT funcionan.
Procedo a copia el SC4Fix.dll en la carpeta plugins y cuando arranco el juego una ventana me dice, en resumen, que el .dll no funciona sobre la versión .638.
Compruebo la versión de nuevo en la carpeta raíz y así es no se actualizó a la versión .640
Desistí del problema y seguí jugando y aprendiendo a usar el NAM conviviendo con el problema del Crash-to-Desktop
Ahora también he descubierto que existe un bug original con la demanda R·$$$ en la I-AT (I-HT) y el parche que he encontrado, me exige tener la versión .640

He desinstalado todo, incluido el juego y he seguido todo el proceso, leyendo de nuevo todas las instrucciones para intentar hacerlo bien, pero mi problema persiste.

¿Que puedo hacer? ¿Como puedo actualizarlo, o en su defecto solucionar estos problemas y/o bugs?; ya que he leído que hay varios bugs más con sus respectivos parches.

He intentado buscar una solución por el foro de SC4Devotion y en Simtropolis también y no he encontrado nada.
Si la solución ya existe, por favor disculparme por repetirlo.
Disculparme por haberme extendido tanto, pero querías explicar lo bien, al menos lo que he considerado importante.

Por cierto, uso Windows 7

Muchas gracias. Un saludo.

Offline Zenist

Re: Problema al actualizar de versión .638 a .640
« Reply #1 on: December 02, 2017, 02:10:34 PM »
Hola, primero que todo ¡bienvenido al mundo de Simcity 4!.

Primero que todo, y para evitar algunos bugs, deberías establecer como directorio de la carpeta del contenido la siguiente dirección

Quote
C:\My Documents\

Esto evita problemas como las luces nocturnas de los BAT que descargues. Para hacerlo solo debes seleccionar la carpeta de tus documentos (Mis documentos), seleccionas la pestaña "ubicación" y luego copias la dirección que te dejé arriba.

En tanto el NAM y sus respectivos parches, tengo entendido que no es del todo necesario descargar el GMax, solo bastan los parches del juego. Quizás se te crashea el juego cuando pones piezas de NWM sobre bats o lots, algo que a mi me bugeaba el juego hasta que lo compré digital.

Recuerda que el Simcity es un juego viejísimo que presenta problemas por montones en plataformas más nuevas como Windows 7 ó 10, por lo que, repito, te aconsejo que lo pilles por alguna barata de tiendas digitales  (Steam, Origin etc.), te darás cuenta que, aparte de estar totalmente parcheado el juego, tendrás una experiencia de juego mejor que la versión de CD, yo lo compré por poco de más de 4 dólares hace algunos meses en Steam  :D

Espero que la respuesta te ayude en algo, si no lo hace, puedes preguntar de nuevo, a pesar de que no participo mucho acá, sé que es una comunidad muy buena.

Saludos  :thumbsup:



Offline Alberto García Pastor

Re: Problema al actualizar de versión .638 a .640
« Reply #2 on: December 11, 2017, 02:26:02 PM »
Gracias Zenist.
Como nadie más me respondió (supongo que el castellano no se usa mucho por estos sitios), decidí hacerte caso... al pie de la letra.
Hice mi compra en Steam a menos de 4$ (tuve que buscar un poco).
Con el SC4fix, el NAM funciona perfectamente y todo lo demás también.
Un saludo,

Offline huzman

Re: Problema al actualizar de versión .638 a .640
« Reply #3 on: December 12, 2017, 09:33:28 AM »
hola "castellaneros",
Dos puntos de vista:
1) Ni piensen ir al sitio de Origin. Esa versión es la mas mala de todas.
2) En Simtropolis hay un club en español si os interesa.
« Essayez d’apprendre quelque chose sur tout et tout sur quelque chose. »
             « Try to learn something about everything and everything about something »
                          « Trata de aprender algo sobre todo y todo sobre algo »
                                                                                                    — Thomas Henry Huxley

Offline kelis

  • Team EBLT
  • Forums Parliamentarian
  • *
  • Posts: 1569
  • Total likes: 275
  • Reputation: 2
  • || Mijn eigen Wereld ||
    • ~ Kelis Bat Design ~
  • CL:
    Puerta del Mundo
Re: Problema al actualizar de versión .638 a .640
« Reply #4 on: December 12, 2017, 11:18:48 AM »
Hola Alberto.

Cualquier duda que tengas no dudes en compartirla con nosotros, te ayudaremos lo antes posible.

Un saludo y espero que disfrutes mucho de este juegazo  :thumbsup:
.                                                                                                                      

                                                                                     || Benelux Team || Windows on the World || My Photos on Flickr || Kelis BNL Projects ||

Offline Alberto García Pastor

Re: Problema al actualizar de versión .638 a .640
« Reply #5 on: December 13, 2017, 08:08:05 AM »
hola "castellaneros",
Dos puntos de vista:
1) Ni piensen ir al sitio de Origin. Esa versión es la mas mala de todas.
2) En Simtropolis hay un club en español si os interesa.

1) Steam funciona con todo (lots, BAT's, mods, o cualquier cosa que haya metido hasta ahora en la carpeta de plugins), sin problemas.
2) ¿Si? Tengo que buscarlo. Los foros en inglés a veces me cuesta traducirlos y/o entenderlos.

Gracias huzman. :thumbsup:

Offline huzman

Re: Problema al actualizar de versión .638 a .640
« Reply #6 on: December 13, 2017, 11:11:39 AM »
1) Estoy hablando de la versión de Origin. Es una versión que no se puede mejorar hacia v640 o v641. Tampoco acepta el SC4Fix y otras cosas importantes.
2) Simplemente vas a ST, vas a Clubs, y escojas el club en español sin hablar inglés ni comer hamburguesas.
« Essayez d’apprendre quelque chose sur tout et tout sur quelque chose. »
             « Try to learn something about everything and everything about something »
                          « Trata de aprender algo sobre todo y todo sobre algo »
                                                                                                    — Thomas Henry Huxley