Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: Problem with directory names and Japanese mods  (Read 10672 times)

0 Members and 1 Guest are viewing this topic.

Offline Speth

Problem with directory names and Japanese mods
« on: January 26, 2013, 03:52:33 PM »
Sorry if this has already been asked, I couldn't find anything about it though:

I've been trying to get this great looking sidewalk mod to work:
http://hide-inoki.com/bbs/phpbb2/viewtopic.php?t=856&start=0&postdays=0&postorder=asc&highlight=

However, when i unRAR it i get this error message, and the electricity poles don't appear in my game:
Quote
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Cannot create z_zJPN_SideWalk_Mod2\zPlopFile\03_Road\X+|Xg\Neko_Post_Road_Desc.dat
!   The filename, directory name, or volume label syntax is incorrect.
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Attempting to correct the invalid file name
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Renaming z_zJPN_SideWalk_Mod2\zPlopFile\03_Road\X+|Xg\Neko_Post_Road_Desc.dat to z_zJPN_SideWalk_Mod2\zPlopFile\03_Road\X+_Xg\Neko_Post_Road_Desc.dat
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Cannot create z_zJPN_SideWalk_Mod2\zPlopFile\05_Aveune\X+|Xg\Neko_Post_Aveune_Desc.dat
!   The filename, directory name, or volume label syntax is incorrect.
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Attempting to correct the invalid file name
!   C:\Users\Stephen\Downloads\SC4 zips\z_zJPN_SideWalk_Mod2 (1).zip: Renaming z_zJPN_SideWalk_Mod2\zPlopFile\05_Aveune\X+|Xg\Neko_Post_Aveune_Desc.dat to z_zJPN_SideWalk_Mod2\zPlopFile\05_Aveune\X+_Xg\Neko_Post_Aveune_Desc.dat

I think this won't even show up properly in this forum, as it involves a weird character displayed at the "X" position in the string: "X". This character is a weird "vertical line" one. Because the directories don't get a proper filename and winRAR renames them to something slightly different, the plugin can't find its .dat file. I'm assuming this has something to do with Japanese fonts and Windows. However, I think I do have the Japanese language pack installed so I'm not sure what the problem is (and other Japanese mods seem to work fine with my cities).

Anyone who found a way to solve this?

Offline vortext

  • Administrator
  • Forums Guru
  • *
  • Posts: 3364
  • Total likes: 576
  • Reputation: 23
  • CL:
    Street Smarts
Re: Problem with directory names and Japanese mods
« Reply #1 on: January 26, 2013, 04:02:13 PM »
It's because of the weird characters indeed, I've run into similar problems in the past. Renaming the folder names should do the trick. Otherwise, try to unpack the single files into new folders. Hope this helps.  :)
time flies like a bird
fruit flies like a banana

Offline Speth

Re: Problem with directory names and Japanese mods
« Reply #2 on: January 26, 2013, 04:12:43 PM »
It's because of the weird characters indeed, I've run into similar problems in the past. Renaming the folder names should do the trick. Otherwise, try to unpack the single files into new folders. Hope this helps.  :)

Hmm but strangely, the files do end up on my computer, in fact winrar itself renames the directories for me (it just replaces the invalid character with an underscore). Does it matter for plugins whether their dependencies are in a folder with a certain name? If not, then the problem might actually be caused by something else...

Offline vortext

  • Administrator
  • Forums Guru
  • *
  • Posts: 3364
  • Total likes: 576
  • Reputation: 23
  • CL:
    Street Smarts
Re: Problem with directory names and Japanese mods
« Reply #3 on: January 26, 2013, 04:21:47 PM »
Does it matter for plugins whether their dependencies are in a folder with a certain name?

No, its does not. Hence my suggestion to rename the folders.


If not, then the problem might actually be caused by something else...

afaik, the problem is special characters will not be properly recognized by certain programs, despite the character set being installed on the pc they're running on. For instance, I've noticed if a folder name has a & in its name, the LE wont load it. So I stick to the alphabet and numericals and everything works fine.  :)
time flies like a bird
fruit flies like a banana

Offline Speth

Re: Problem with directory names and Japanese mods
« Reply #4 on: January 26, 2013, 05:08:58 PM »
Nevermind, I got it working!

Turns out, I was just dumb, after the file was properly installed I just had to replop some of the roads to get the props to appear. The directory name wasn't even the real issue. Thanks anyway! Here's what my city looks like now:

Offline vortext

  • Administrator
  • Forums Guru
  • *
  • Posts: 3364
  • Total likes: 576
  • Reputation: 23
  • CL:
    Street Smarts
Re: Problem with directory names and Japanese mods
« Reply #5 on: January 26, 2013, 05:12:01 PM »
Sweet city, you should post more pictures sometime!  :thumbsup:
time flies like a bird
fruit flies like a banana