Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat

Author Topic: iLives Reader 1.x Official support thread  (Read 127092 times)

0 Members and 1 Guest are viewing this topic.

Offline speeder

Re: iLives Reader 1.x Official support thread
« Reply #220 on: February 24, 2016, 04:15:59 PM »
Yeah... I take back my last post :P

Just attempting to do a extremely simple fix made me understand why you decided to write a new reader from scratch.

Offline cmdp123789

Re: iLives Reader 1.x Official support thread
« Reply #221 on: March 28, 2016, 07:56:09 PM »


What is going on? I dont understand what is happening, everything is showing up as unknown.. help?

Offline twalsh102

  • Forums Councilmember
  • *
  • Posts: 99
  • Total likes: 83
  • Reputation: 2
  • Your slogan here
Re: iLives Reader 1.x Official support thread
« Reply #222 on: March 28, 2016, 08:53:12 PM »
I'll admit that I'm not an expert on this program, but some simple troubleshooting steps come immediately to mind.
1.  When you say "everything is showing up as unknown," are you talking only this one file, or every file you open?
2.  What version of the reader are you using?  What your screenshot shows isn't anything like what I see when I open v. 1.5.3b (which I think is the latest version).  If your version is much older, you might consider upgrading to the latest version.
3.  To make sure you aren't just looking at corrupted files, you might open the file in some other tool that shows the file contents (SC4Tool or SC4PIM come to mind).
4.  If the version of Reader that you are using has worked for you recently, you might consider reinstalling what you have.  What you're seeing might be a result of corrupted Reader program files.

Offline mgb204

Re: iLives Reader 1.x Official support thread
« Reply #223 on: March 28, 2016, 10:47:55 PM »
If it's just this file, I'd assume there is something wrong with it.

You could try taking another lot exemplar (copy), open it in another reader window (instance) then adjusting all the simple properties to match the file in question.

All the long lines are the textures, props etc on the lot. With luck, if you only copy/paste these into the new modified exemplar (removing any from the template first), it may just keep the lot and fix the problem. Usually all but one of the LotConfigPropertyObject lines shown unknown anyway. With some more copy/pasting, you could probably restore the top line manually too if you needed to. Don't forget to ID the new lot file correctly afterwards and Reindex the LotConfig.

I hope that makes sense.

BTW, the image shows reader .093. I have to admit, like many, I use it in preference to the newer version.

Offline c.p.

  • BSC Team
  • Forums Senator
  • *
  • Posts: 645
  • Total likes: 884
  • Reputation: 12
  • CL:
    SC4D Green Thumb
Re: iLives Reader 1.x Official support thread
« Reply #224 on: March 29, 2016, 12:15:54 AM »
There should be a file called tropod_Properties.xml in the same folder as the reader.exe program.  Perhaps if that got moved or deleted it could cause a problem like you are having(?)  (Just a guess.)

Offline cmdp123789

Re: iLives Reader 1.x Official support thread
« Reply #225 on: March 29, 2016, 10:03:20 AM »
Thanks for the quick replies guys! Honestly, I don't know what it was, but I simply took the 0.93 version, and went back to the 1st page, and I believe I have now the 1.4 version? where do I get the latest one?

Offline vester

  • Administrator
  • Forums Legend
  • *
  • Posts: 4842
  • Total likes: 688
  • Reputation: 27
    • My bat cave.
  • CL: Tickets Please
Re: iLives Reader 1.x Official support thread
« Reply #226 on: March 29, 2016, 11:06:46 AM »
You got it.

The 1.5 version is the latest. You find a download link in this post.
(See the top of the first post in this thread.)
« Last Edit: March 29, 2016, 11:09:05 AM by vester »

Offline Wournos

Re: iLives Reader 1.x Official support thread
« Reply #227 on: April 02, 2016, 01:34:26 AM »
The iLives installer gives me this message:

"Unable to install because a newer version of this product is already installed."

This is the message I get when trying to setup the MS2010 runtime libraries:

Setup has detected that this computer does not meet the requirements to install this software. The following blocking issue must be resolved before you can install Microsoft visual C++ 2010 x86 Redistribution Setup software package.

Please Resolve the following:
A newer version of Microsoft Visual C++ 2010 redistribution has been detected on the machine

Are you able to uninstall & then reinstall both the reader and MSVC? Otherwise someone would need to look at source code to see if that can be updated.
I have the same issue trying to install v152. The program cannot be installed due to this message.

Version 151 works though and I have been trying to change the Rep value on some train stations I have downloaded because they have the wrong capacity on Mac, but when I locate the exemplar file, double-click it to edit, the Rep field is greyed out and I cannot change the value to 0 (as suggested over at Simtropolis).
What do I do?

Offline InvisiChem

  • Forums Mayor
  • *
  • Posts: 201
  • Total likes: 34
  • Reputation: 3
  • I woke up breathing. It's a good day.
Re: iLives Reader 1.x Official support thread
« Reply #228 on: April 02, 2016, 02:16:56 AM »
I run version 1.54 on windows 10 64 bit with no issues. Was running it on 7 64 bit and 8.1 64bit without issues. Here is the post with the link http://sc4devotion.com/forums/index.php?topic=10417.msg498883#msg498883.

If I remember right, have to reread the posts to be sure, but 1.52 had this issue and was fixed by 1.53. Don't quote me, been awhile, including a nickname change, since I read that.
Everyone has something to offer, most do not possess the courage to offer it.

Offline Wournos

Re: iLives Reader 1.x Official support thread
« Reply #229 on: April 02, 2016, 05:16:25 AM »
I run version 1.54 on windows 10 64 bit with no issues. Was running it on 7 64 bit and 8.1 64bit without issues. Here is the post with the link http://sc4devotion.com/forums/index.php?topic=10417.msg498883#msg498883.

If I remember right, have to reread the posts to be sure, but 1.52 had this issue and was fixed by 1.53. Don't quote me, been awhile, including a nickname change, since I read that.
Tried to install this. I get a bunch of files and an Installer folder with several sub folders (32, 32d, 32v90, 32v90d), all but one (32) containing setup files. Which one do I pick?

Offline mgb204

Re: iLives Reader 1.x Official support thread
« Reply #230 on: April 02, 2016, 07:48:36 AM »
If you get the error re: Microsoft Visual C++ 2010, there is one important thing you should check. On a 64-Bit OS, you may have the 64-Bit version installed. In which case also install the 32-Bit version.

I had problems because I failed to install the 32-Bit runtime, thinking the 64-Bit runtime would be sufficient.

Offline InvisiChem

  • Forums Mayor
  • *
  • Posts: 201
  • Total likes: 34
  • Reputation: 3
  • I woke up breathing. It's a good day.
Re: iLives Reader 1.x Official support thread
« Reply #231 on: April 02, 2016, 10:47:23 AM »
You clicked the source code link. Try the one above that. lol.
Everyone has something to offer, most do not possess the courage to offer it.

Offline Edvarz

Re: iLives Reader 1.x Official support thread
« Reply #232 on: April 29, 2016, 05:07:57 PM »
Hi, just a little question. I installed version 1.54 without uninstalling version 0.93, in fact I couldn't uninstall it didn't find an uninstal.exe and I also couldn't do it from the Windows Control Panel (I'm guessing some program messed with the registry). I'm using a 64bit Windows7. The weird thing is that both versions seem to work. So can I have them both installed on my computer?
Sorry if it's a stupid question. I just know the basics about computers. Thanks!

Offline NCGAIO

Re: iLives Reader 1.x Official support thread
« Reply #233 on: April 29, 2016, 05:54:21 PM »

Unless  has made one manual registry the reader vs 0.93 will not show up for uninstallation  why this version is just to unzip in paste..


For remember ... in  64Bit  windows environments all 32bit process is run on emulation (wow64) and do not share.


  DLLs and other characteristics can be observed in

- -WOW64 Implementation Details


- -Running 32-bit Applications


Nc
« Last Edit: April 29, 2016, 06:33:23 PM by NCGAIO »

Offline Tropod

Re: iLives Reader 1.x Official support thread
« Reply #234 on: April 29, 2016, 08:54:06 PM »
Hi, just a little question. I installed version 1.54 without uninstalling version 0.93, in fact I couldn't uninstall it didn't find an uninstal.exe and I also couldn't do it from the Windows Control Panel (I'm guessing some program messed with the registry). I'm using a 64bit Windows7. The weird thing is that both versions seem to work. So can I have them both installed on my computer?
Sorry if it's a stupid question. I just know the basics about computers. Thanks!

Yes, you can use both. v0.93 doesn't actually do an install, whereas v1.54 does.

Offline Edvarz

Re: iLives Reader 1.x Official support thread
« Reply #235 on: April 30, 2016, 12:02:54 AM »
Hi, just a little question. I installed version 1.54 without uninstalling version 0.93, in fact I couldn't uninstall it didn't find an uninstal.exe and I also couldn't do it from the Windows Control Panel (I'm guessing some program messed with the registry). I'm using a 64bit Windows7. The weird thing is that both versions seem to work. So can I have them both installed on my computer?
Sorry if it's a stupid question. I just know the basics about computers. Thanks!

Yes, you can use both. v0.93 doesn't actually do an install, whereas v1.54 does.

Oh, I see now. Thanks a bunch!

Offline woodb3kmaster

Re: iLives Reader 1.x Official support thread
« Reply #236 on: July 25, 2016, 02:18:32 AM »
Following my recent issues with custom lot icons, I thought it best to point out that Reader tends to corrupt files inserted into DATs. I've seen it happen with both PNGs and LTEXTs, but not always. Often the corruption occurs when I save the DAT, though I wouldn't rule out the possibility that it happens immediately on insertion as well. (For the record, I've been using v1.52, though I have the v1.54 installer on my hard drive.)

Feel brand new. Be inspired.
NYHAVEN - VIEWS FROM WITHIN
Nuclear City - 5/8

Offline jdenm8

  • NAM Team
  • Forums Guru
  • *
  • Posts: 2095
  • Total likes: 1
  • Reputation: 6
  • AAAAAAAAAAAA!
    • CSGforums
  • CL:
    Simphony Conductor
Re: iLives Reader 1.x Official support thread
« Reply #237 on: July 25, 2016, 05:00:31 AM »
I don't recall if the non-compressed file corruption bug was ever fixed. If I recall correctly, it would corrupt any uncompressed files after a compressed file (When sorted by the NUM). This happens regardless of subfile type; I've had it happen to PNGs, LTEXTs, Exemplars, Effect Dirs, etc.


"We’re making SimCity, not some dopey casual game." -Ocean Quigley

Offline mgb204

Re: iLives Reader 1.x Official support thread
« Reply #238 on: July 25, 2016, 05:47:05 AM »
I think you should update to the latest version, because I think this bug was finally squashed. I didn't realise you were using one of the older revisions. I've quickly done some tests importing both compressed and uncompressed icons, neither operation caused any issues with the file. This is using reader 1.5.4.

Offline twalsh102

  • Forums Councilmember
  • *
  • Posts: 99
  • Total likes: 83
  • Reputation: 2
  • Your slogan here
Re: iLives Reader 1.x Official support thread
« Reply #239 on: July 25, 2016, 01:39:21 PM »
The iLives installer gives me this message:

In reference to the issue of receiving the following error when trying to install v1.54:

"Setup has detected that this computer does not meet the requirements to install this software. The following blocking issue must be resolved before you can install Microsoft visual C++ 2010 x86 Redistribution Setup software package.

Please Resolve the following:
A newer version of Microsoft Visual C++ 2010 redistribution has been detected on the machine"

I've discovered the following:  This is a Microsoft error and has nothing to do with iReader.  The following link explains in some detail:

https://blogs.msdn.microsoft.com/vsnetsetup/2014/07/17/installation-failing-with-a-newer-version-of-microsoft-visual-c-2010-redistributable-has-been-detected-on-this-machine/

I found the easiest thing to do is to uninstall any existing versions of the 2010 redistributable per the above link.  Then you have a choice of downloading the package(s) directly from Microsoft, or letting the iReader setup program install it.  If you download from Microsoft and install separately, the iReader setup program will recognize the correct version of the redistributable, and immediately launch the setup of iReader.

Make sure you uninstall the x64 version if you had it installed, as it apparently suffered the same problem.  Just download the x64 package from Microsoft and reinstall separately.