SC4D Homepage
BSC File Exchange
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length


Author Topic: Adding icon means lot refuses to load??  (Read 399 times)

0 Members and 1 Guest are viewing this topic.

Offline tomvsotis

Adding icon means lot refuses to load??
« on: January 23, 2019, 08:35:39 AM »
Hey all, having some trouble with adding an icon to a newly created lot. The lot is a pretty simple eyecandy landmark that I'm using to test out the model i made earlier. It works fine as initially exported; the lot appears in the landmark menu, and plops perfectly well. But for some reason, adding an icon to the .SC4Lot file with LEProp causes the lot to disappear from the landmark menu. I created the icon in Photoshop, and exported it as a flattened PNG, 176 x 44. I've tried it with and without transparency/alpha channels enabled, and also tried it as a JPG. No good. If there's any sort of icon added, it won't load. Has anyone come across this problem before?

Sim City 4 Devotion Forums

Adding icon means lot refuses to load??
« on: January 23, 2019, 08:35:39 AM »

Re: Adding icon means lot refuses to load??

Offline mgb204

Re: Adding icon means lot refuses to load??
« Reply #1 on: January 23, 2019, 09:30:03 AM »
LE Prop is buggy and if the item is missing from the menus, almost certainly it has corrupted either the Icon itself or the Index (Dir) file.

Two better methods for adding icons:

  • SC4 PIM (PIM-X) can add icons, just right click on the Lot and select "Change Icon", then browse to the correct file.
  • Reader can be useful if you've more than one icon to add. Right click on the left pane and select "Insert & Compress File", then browse for your icon (needs to be in PNG format). You will need to then tell Reader what type of file it is, PNG. Lastly, you need to add the TGI ID for the icon manually. However, if the original icon is still in the file, right click that and select "Copy Entry ID". Then select your new icon, right click that and select "Paste Entry ID". You can then safely remove the original icon. Note to see the change, you must click another item, then back on the new icon for the ID to update.

Sim City 4 Devotion Forums

Re: Adding icon means lot refuses to load??
« Reply #1 on: January 23, 2019, 09:30:03 AM »

Re: Adding icon means lot refuses to load??

Offline Andreas

  • *
  • *
  • *
  • *
  • *
  • *
  • Posts: 4709
  • Country: de
  • Total likes: 908
  • Reputation: 33
  • Gender: Male
    • SimCityPlaza
  • CL: ()bobby() Transit Controller
Re: Adding icon means lot refuses to load??
« Reply #2 on: January 23, 2019, 10:15:49 AM »
Hmm, I've been using LEProp for quickly changing the icon many times without any problems, maybe you can verify the problem with another lot and/or an icon graphics that you exported from somewhere else? If the SC4Lot file has a "standard layout" (no different content merged in etc.), opening the lot in LE, changing the icon PNG, clicking "Apply" and then "Save DAT" should work as expected. It is a good idea to check the broken (?) lot with the Reader or another modding tool and see if something went wrong, though.
Andreas

Sim City 4 Devotion Forums

Re: Adding icon means lot refuses to load??
« Reply #2 on: January 23, 2019, 10:15:49 AM »

Re: Adding icon means lot refuses to load??

Offline mgb204

Re: Adding icon means lot refuses to load??
« Reply #3 on: January 23, 2019, 11:41:41 AM »
I'm not saying LEProp doesn't work, just that it can easily corrupt files. If I recall correctly, ensuring you only save one change at a time is key to avoid problems. However, if you are already using SC4-PIM, it's almost a no-brainier to use that to add the icon, since it saves using another application.

Sim City 4 Devotion Forums

Re: Adding icon means lot refuses to load??
« Reply #3 on: January 23, 2019, 11:41:41 AM »

Re: Adding icon means lot refuses to load??

Offline tomvsotis

Re: Adding icon means lot refuses to load??
« Reply #4 on: January 23, 2019, 07:04:41 PM »
Ah, thanks -- i somehow missed that you can add icons with PIM-X. It works fine. Thanks!

Sim City 4 Devotion Forums

Re: Adding icon means lot refuses to load??
« Reply #4 on: January 23, 2019, 07:04:41 PM »

 


If you experience visual glitches in our site, we strongly suggest you to use Firefox to browse the forums. Also a 1024*768 or higher resolution is highly recommended to view this site

SMF 2.0.15 | SMF © 2017, Simple Machines
TinyPortal © 2005-2011
SMFAds for Free Forums

Page created in 0.339 seconds with 60 queries.