SC4D Homepage
BSC File Exchange
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length


Author Topic: Is sound always missing a but or I did it wrong  (Read 2534 times)

0 Members and 1 Guest are viewing this topic.

Offline texture112233

Is sound always missing a but or I did it wrong
« on: July 13, 2016, 06:58:57 AM »
Why query sound always missing in the dependencies list even though I have already put sound.dat into plugin folder and load it with pim-x?
I think this is a bug. The default GroupID of query sound should be 2A4D193D but PIM-X make it CA4D1943. As far as I known, the SFX:Query sound property only store the InstanceID,by which time the default T&G ID should be provided by PIM-X to trace the TRK file. If you make it wrong you will never be able to trace it correctly.
And I am very curious why not fix it. Even in the guide we can see the "not found".
More important is how to fix it?





Sim City 4 Devotion Forums

Is sound always missing a but or I did it wrong
« on: July 13, 2016, 06:58:57 AM »

Re: Is sound always missing a but or I did it wrong

Offline vortext

Re: Is sound always missing a but or I did it wrong
« Reply #1 on: July 13, 2016, 07:45:09 AM »
Hm good question. As far as I can tell it's not a bug, nor did you do anything wrong, but just a quirk of SC4PIM.

If you check for example Maxis vanilla lots in SC4PIM you'll notice the sound is reported missing as well.

Sounds are typically handled in the Building Exemplar by means of various SFX properties (e.g. SFX:Query Sound), which are handled by SC4PIM just fine. At least I've not heard of any actual, ingame errors regarding sound thus far. Then again, I've completely turned off all game sounds anyway so I couldn't tell if sounds were missing to begin with.  :D
« Last Edit: July 13, 2016, 12:12:16 PM by vortext »

time flies like a bird
fruit flies like a banana

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #1 on: July 13, 2016, 07:45:09 AM »

Re: Is sound always missing a but or I did it wrong

Offline texture112233

Re: Is sound always missing a but or I did it wrong
« Reply #2 on: July 13, 2016, 08:18:05 AM »
First of all, thank you for your rapid reply!
Yes, a lot do not have any properties of query sound, but a building examplar have.
What PIM-X will do is to trace every possible building on this lot according to the LotConfigPropertyLotObject properties, fetch their model/sound/ltext, display them in the dependencies list.
I traced it with "Open buildings from this lot" and found the missing ID in the building exemplar's property. That is to say, it do exists, just the pim-x cannot trace it correctly.
Above all, I insist that it's a bug, rather than a quirk.
Do you have Wouanagaine's email?
« Last Edit: July 13, 2016, 08:19:47 AM by texture112233 »

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #2 on: July 13, 2016, 08:18:05 AM »

Re: Is sound always missing a but or I did it wrong

Offline vortext

Re: Is sound always missing a but or I did it wrong
« Reply #3 on: July 13, 2016, 08:32:36 AM »
Well imho a bug would imply the sounds do not work ingame, which isn't the case afaik.

At any rate, if you want to get to the root of the issue your best bet would indeed be to send Wouanagaine a PM, however, he hasn't been around since September 2014 so not sure if you'd get a reply. Worth a shot though.
« Last Edit: July 13, 2016, 12:23:37 PM by vortext »

time flies like a bird
fruit flies like a banana

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #3 on: July 13, 2016, 08:32:36 AM »

Re: Is sound always missing a but or I did it wrong

Offline texture112233

Re: Is sound always missing a but or I did it wrong
« Reply #4 on: July 13, 2016, 08:46:38 AM »
No..let's start over.
1.the sound do exists. Let's assume it's TGI = 0b8d821a,2a4d193d,0xKKKKKKKK.
2.the game works perfectly.
3.the Instance ID of the query sound(0xKKKKKKKK) is stored in the building exemplar(SFX:Query Sound). The reason why only Instance is stored is because all query sound's T/G is same(0b8d821a, 2a4d193d). No need to store redundant data.
4.PIM was supposed to use 0b8d821a,2a4d193d,0xKKKKKKKK to trace the sound, but it may made a mistake and used 0b8d821a,ca4d1943,0xKKKKKKKK to trece the sound instead. As a result, it will never succeed to trace it.

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #4 on: July 13, 2016, 08:46:38 AM »

Re: Is sound always missing a but or I did it wrong

Offline vortext

Re: Is sound always missing a but or I did it wrong
« Reply #5 on: July 13, 2016, 09:20:00 AM »
Yes I understand all that. My point was SC4PIM even reports missing sound for Maxis buildings, which is obviously false and hence does not seem to affect game functionality. As such I'd consider it a cosmetic bug at best because of course you're right SC4PIM should display it properly.

time flies like a bird
fruit flies like a banana

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #5 on: July 13, 2016, 09:20:00 AM »

Re: Is sound always missing a but or I did it wrong

Offline NCGAIO

Re: Is sound always missing a but or I did it wrong
« Reply #6 on: July 13, 2016, 11:23:11 AM »

As  audio enabled  makes no difference to the logic of the game and how in the current systems the best option is to have it off to avoid execution problems is very unlikely that someone look into this.


Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #6 on: July 13, 2016, 11:23:11 AM »

Re: Is sound always missing a but or I did it wrong

Offline vortext

Re: Is sound always missing a but or I did it wrong
« Reply #7 on: July 13, 2016, 12:02:04 PM »
Couldn't resist and turned on sound for a quick check lots made with SC4PIM have query sound: they do. At least R$ does.

Also noticed repeated query of the same lot generates a number of different sound effects, so the IID doesn't correspond to a single query sound.
« Last Edit: July 13, 2016, 12:15:30 PM by vortext »

time flies like a bird
fruit flies like a banana

Sim City 4 Devotion Forums

Re: Is sound always missing a but or I did it wrong
« Reply #7 on: July 13, 2016, 12:02:04 PM »

 


If you experience visual glitches in our site, we strongly suggest you to use Firefox to browse the forums. Also a 1024*768 or higher resolution is highly recommended to view this site

SMF 2.0.15 | SMF © 2017, Simple Machines
TinyPortal © 2005-2011
SMFAds for Free Forums

Page created in 0.435 seconds with 68 queries.