LEX Latest Uploads

Menu

LEX File Exchange
EA Support Files
SC4 Wikipedia
Network Addon Mod
Dependencies
Chat
Welcome, Guest. Please login or register.
Did you miss your activation email?

April 15, 2021, 09:09:58 PM

Login with username, password and session length

Author Topic: Help with wrong custom textures displaying?  (Read 3370 times)

0 Members and 1 Guest are viewing this topic.

Offline tomvsotis

Help with wrong custom textures displaying?
« on: February 11, 2016, 11:54:59 PM »
OK, this is my first attempt at making my own lots, and I've run into a strange problem, for which I'm sure (or at least I hope) there's a simple solution:

I decided to make lots for seamless transitions between the grass textures for various wealth levels (along the lines of these http://community.simtropolis.com/files/file/29797-mgb-diagonal-filler-set/, but not diagonal and with a smooth transition, rather than a distinct line.) I exported the textures from Simcity2.dat, converted them to PNG, imported them into Photoshop, and made three nice new textures, each with a seamless blend between the grasses.

I used SC4Tool to make new textures with these PNGs, within the texture range I got on the thread here, and then made a DAT file in Reader, into which i saved the three new textures. And, finally, I made three new Lots, each with one of the new textures as a base texture. Everything looked great! Except...

...in-game, the three lots all display with the same texture, which is the first one I saved. I've triple-checked that I haven't messed it up in the Lot Editor, but no, each lot has a different texture. The only thing I can think of is that I've not given them IDs properly? The texture range I was assigned was 0xF8A40000 to 0xF8A7FFFF, so I numbered the new textures as follows (with the final digit varying from 1 to 4 for the different zoom levels):

0xF8A40000
0xF8A41000
0xF8A42000

Any ideas?

Offline mgb204

Re: Help with wrong custom textures displaying?
« Reply #1 on: February 12, 2016, 03:51:07 AM »
The fifth digit is used for wealth. So any textures using 0, 1, 2 or 3 will group together if more than one exists. The texture that appears, depends on the wealth of the lot. Just start at 4 instead of 0-3 for the 5th digit.

I fact, I'd start the other way round, to keep textures grouped together, so my first ID's would be:

0xF8A44000
0xF8A44005
0xF8A4400A


Offline tomvsotis

Re: Help with wrong custom textures displaying?
« Reply #2 on: February 12, 2016, 07:24:11 AM »
Ahhhhhhhhhhhhhhhhhhhhhh OK. Gotcha. Many thanks! :)

Offline tomvsotis

Re: Help with wrong custom textures displaying?
« Reply #3 on: February 12, 2016, 12:45:24 PM »
Yay they work! Thanks again for your help.


Offline Simcoug

  • The NUTS
  • Forums Senator
  • *
  • Posts: 646
  • Total likes: 123
  • Reputation: 5
  • Fruit flies like a... What? Who already has that?
Re: Help with wrong custom textures displaying?
« Reply #4 on: February 12, 2016, 01:18:00 PM »
Those transitions look great  :thumbsup:

Offline tomvsotis

Re: Help with wrong custom textures displaying?
« Reply #5 on: February 12, 2016, 05:07:37 PM »
Those transitions look great  :thumbsup:
aw, thanks! happy to share them if anyone wants them :)